You are not logged in or you do not have permission to access this page. This could be due to one of several reasons:
1.You are not logged in. Fill in the form at the bottom of this page and try again.
2.You may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
3.If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.
Welcome, Guest

Web Service Provider generated services location
(1 viewing) (1) Guest










































































  • Page:
  • 1

TOPIC: Web Service Provider generated services location

09-13-2015 8:06 #1

  • OFFLINE
    Fresh Boarder
  • Join Date: 13-09-2015
    Posts: 1
    Points: 102
Hello,

I am facing the following problem.

I am creating a Web Service Provider using a WSDL file that I get from a different department. (This is the requirement).

After creating the Web Service Provider I get some empty services (only inputs and outputs, no implementation) that are to be implemented according to my desired business logic.

This services are under /../name_of_wsp/services/.

All is OK until the WSDL I have changes.

If the WSDL changes what I do is usually to delete all the generated artifacts and the Web Service Provider and then go back through the process of creating the Web Service Provider.

However if I do this, it means that all the code that I put in the generated services will be lost.

How can this be avoided?

Is there another way to re-create the WSP without deleting the "old" artifacts?

Or can I specify where should the services be stored, so they are not deleted after each re-creation of the WSP.

Thank you for your ideas,
Vlad Turian
  • Page:
  • 1